Jar Mismatch error Resolution

Hi Android Developers,

We generally see this error in our console, prompting us most of times when we import a new project and if it contains androidSupportv4.jar.

Found 3 versions of android-support-v4.jar in the dependency list,
but not all the versions are identical (check is based on SHA-1 only at this time).
All versions of the libraries must be the same at this time.
Versions found are:
Path: D:\Linchpin\Library_sherlock\libs\android-support-v4.jar
Length: 484258
SHA-1: bd6479f5dd592790607e0504e66e0f31c2b4d308
Path: D:\LinchpinRepository\CompressRar\libs\android-support-v4.jar
Length: 484258
SHA-1: bd6479f5dd592790607e0504e66e0f31c2b4d308
Path: D:\Linchpin\BB_ZipperDroidPassword\libs\android-support-v4.jar
Length: 385685
SHA-1: 48c94ae70fa65718b382098237806a5909bb096e
Jar mismatch! Fix your dependencies

 

 

This error is due to different versions of androidSupportv4.jar. To resolve this we can

1. Point every use to single androidSupportv4.jar file. for ex if your project includes some library then both of them (library and your project) should contain same version of androidSupportv4.jar, else jar mismatch error occurs. So either use the same jar file kept in library for your project. 

2. Keep the same version of every androidSupportv4.jar file and that to be updated version. You can find this at <android-sdk>/extras/android/support/v4/androidSupportv4.jar

 

*version here signifies SHA1 version of file. If that is same for all the files no error will be there.

Any other point to resolve this is requested.

 
Linchpin Technologies Pvt Ltd, a mobile app development company India , is globally recognized as enterprise app development company

1,089 total views, 2 views today

Share this OnShare on FacebookTweet about this on TwitterShare on LinkedInShare on Google+

Leave a Reply